aboutsummaryrefslogtreecommitdiff
path: root/python/thonny
diff options
context:
space:
mode:
Diffstat (limited to 'python/thonny')
-rw-r--r--python/thonny/README4
-rw-r--r--python/thonny/thonny.SlackBuild9
-rw-r--r--python/thonny/thonny.info6
3 files changed, 12 insertions, 7 deletions
diff --git a/python/thonny/README b/python/thonny/README
index 80d5095755..85e2afa304 100644
--- a/python/thonny/README
+++ b/python/thonny/README
@@ -6,3 +6,7 @@ to satisfy the dependencies, that should not be a problem.
pygame created with python3 support is an optional dependancy.
esptool is another optional dependancy for communicating with
ROM bootloaders of Espressif ESP8266 and ESP32 chips.
+
+note: python3-platformdirs deps have changed, and so that
+package needs to be rebuilt with the new deps, specifically
+python3-setuptool-scm-opt, to avoid importerrors in thonny.
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 6dc675480d..a4224d8f67 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
# Slackware build script for thonny
-# Copyright 2017-23 Tim Dickson, Scotland
+# Copyright 2017-24 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,15 @@
#version history -edited down in size to first and last 4 updates
#2.2.0b4 1 jan 2018. first version for slackbuilds.org
#editted out :-)
-#4.1.2 16 Aug 2023. version bump
#4.1.3 5 Oct 2023. version bump
#4.1.3 build2 27 Oct 2023. change deps.
#4.1.4 8 Dec 2023. version bump
-
+#4.1.7 20 Dec 2024. version bump
#note. get download link from https://pypi.org/project/thonny/#files
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-4.1.4}
+VERSION=${VERSION:-4.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -74,6 +73,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
diff --git a/python/thonny/thonny.info b/python/thonny/thonny.info
index 6ab6c04ef7..8422f5704c 100644
--- a/python/thonny/thonny.info
+++ b/python/thonny/thonny.info
@@ -1,8 +1,8 @@
PRGNAM="thonny"
-VERSION="4.1.4"
+VERSION="4.1.7"
HOMEPAGE="http://thonny.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/4e/82/994a3aa41bc32b37c9b53fa4fa0c7ad0a6a0f586d85e71f2e2220d1b4c61/thonny-4.1.4.tar.gz"
-MD5SUM="3223eca53ea5b681afb45d0615565d1d"
+DOWNLOAD="https://files.pythonhosted.org/packages/49/9d/4f51f79865f293024d601f9d6e8de367164f59d6892e4635bec0f9692a4e/thonny-4.1.7.tar.gz"
+MD5SUM="97b34f1b958a4e6e2da3289705964738"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-jedi python3-pylint pyserial mypy python3-asttokens send2trash"