aboutsummaryrefslogtreecommitdiff
path: root/python/thonny/thonny.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/thonny/thonny.SlackBuild')
-rw-r--r--python/thonny/thonny.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 6dc675480d..a4224d8f67 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
# Slackware build script for thonny
-# Copyright 2017-23 Tim Dickson, Scotland
+# Copyright 2017-24 Tim Dickson, Scotland
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,15 @@
#version history -edited down in size to first and last 4 updates
#2.2.0b4 1 jan 2018. first version for slackbuilds.org
#editted out :-)
-#4.1.2 16 Aug 2023. version bump
#4.1.3 5 Oct 2023. version bump
#4.1.3 build2 27 Oct 2023. change deps.
#4.1.4 8 Dec 2023. version bump
-
+#4.1.7 20 Dec 2024. version bump
#note. get download link from https://pypi.org/project/thonny/#files
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-4.1.4}
+VERSION=${VERSION:-4.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -74,6 +73,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop