aboutsummaryrefslogtreecommitdiff
path: root/python/python3-icalendar
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-icalendar')
-rw-r--r--python/python3-icalendar/python3-icalendar.SlackBuild22
-rw-r--r--python/python3-icalendar/python3-icalendar.info8
2 files changed, 10 insertions, 20 deletions
diff --git a/python/python3-icalendar/python3-icalendar.SlackBuild b/python/python3-icalendar/python3-icalendar.SlackBuild
index 4e36435810..0a2eb77d53 100644
--- a/python/python3-icalendar/python3-icalendar.SlackBuild
+++ b/python/python3-icalendar/python3-icalendar.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-icalendar
-VERSION=${VERSION:-4.0.9}
+VERSION=${VERSION:-6.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +63,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/python3-icalendar/python3-icalendar.info b/python/python3-icalendar/python3-icalendar.info
index 8b0f55f981..833d91017b 100644
--- a/python/python3-icalendar/python3-icalendar.info
+++ b/python/python3-icalendar/python3-icalendar.info
@@ -1,10 +1,10 @@
PRGNAM="python3-icalendar"
-VERSION="4.0.9"
+VERSION="6.1.1"
HOMEPAGE="https://icalendar.readthedocs.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/1e/4b/b9e53b2fc4f7942c5698842005ad9e55dd4d932434f5bd1cf8acf3d06b01/icalendar-4.0.9.tar.gz"
-MD5SUM="83c9ebbd0e4476fe5a2bd40c5e54c344"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/i/icalendar/icalendar-6.1.1.tar.gz"
+MD5SUM="228d80d99d00ad0353c4e5b5b28e3000"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-pytz python3-dateutil"
+REQUIRES="python3-pytz python3-dateutil python3-hatch_vcs"
MAINTAINER="Tonus"
EMAIL="tonus1@free.fr"