aboutsummaryrefslogtreecommitdiff
path: root/python/python3-icalendar/python3-icalendar.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-icalendar/python3-icalendar.SlackBuild')
-rw-r--r--python/python3-icalendar/python3-icalendar.SlackBuild22
1 files changed, 6 insertions, 16 deletions
diff --git a/python/python3-icalendar/python3-icalendar.SlackBuild b/python/python3-icalendar/python3-icalendar.SlackBuild
index 4e36435810..0a2eb77d53 100644
--- a/python/python3-icalendar/python3-icalendar.SlackBuild
+++ b/python/python3-icalendar/python3-icalendar.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-icalendar
-VERSION=${VERSION:-4.0.9}
+VERSION=${VERSION:-6.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +63,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \