aboutsummaryrefslogtreecommitdiff
path: root/python/buildbot-worker
diff options
context:
space:
mode:
Diffstat (limited to 'python/buildbot-worker')
-rw-r--r--python/buildbot-worker/buildbot-worker.SlackBuild5
-rw-r--r--python/buildbot-worker/buildbot-worker.info6
2 files changed, 7 insertions, 4 deletions
diff --git a/python/buildbot-worker/buildbot-worker.SlackBuild b/python/buildbot-worker/buildbot-worker.SlackBuild
index beda1c958f..7c1e6d6538 100644
--- a/python/buildbot-worker/buildbot-worker.SlackBuild
+++ b/python/buildbot-worker/buildbot-worker.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=buildbot-worker
SRCNAM=${PRGNAM//-/_}
-VERSION=${VERSION:-3.11.3}
+VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,6 +83,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/buildbot-worker/buildbot-worker.info b/python/buildbot-worker/buildbot-worker.info
index 8f3be6f993..4e931a8c6c 100644
--- a/python/buildbot-worker/buildbot-worker.info
+++ b/python/buildbot-worker/buildbot-worker.info
@@ -1,8 +1,8 @@
PRGNAM="buildbot-worker"
-VERSION="3.11.3"
+VERSION="4.2.1"
HOMEPAGE="https://pypi.python.org/pypi/buildbot-worker"
-DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot_worker/buildbot_worker-3.11.3.tar.gz"
-MD5SUM="78ed8e19ff4caa734487e2880f98408b"
+DOWNLOAD="https://pypi.python.org/packages/source/b/buildbot_worker/buildbot_worker-4.2.1.tar.gz"
+MD5SUM="839d5e5062a0d81a36822cc922f76979"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-twisted python3-autobahn msgpack-python"