aboutsummaryrefslogtreecommitdiff
path: root/python/buildbot-worker/buildbot-worker.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/buildbot-worker/buildbot-worker.SlackBuild')
-rw-r--r--python/buildbot-worker/buildbot-worker.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/buildbot-worker/buildbot-worker.SlackBuild b/python/buildbot-worker/buildbot-worker.SlackBuild
index beda1c958f..7c1e6d6538 100644
--- a/python/buildbot-worker/buildbot-worker.SlackBuild
+++ b/python/buildbot-worker/buildbot-worker.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=buildbot-worker
SRCNAM=${PRGNAM//-/_}
-VERSION=${VERSION:-3.11.3}
+VERSION=${VERSION:-4.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,6 +83,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \