aboutsummaryrefslogtreecommitdiff
path: root/games/vkQuake
diff options
context:
space:
mode:
Diffstat (limited to 'games/vkQuake')
-rw-r--r--games/vkQuake/fix_minalloc_make.patch49
-rw-r--r--games/vkQuake/vkQuake.SlackBuild4
-rw-r--r--games/vkQuake/vkQuake.info6
3 files changed, 55 insertions, 4 deletions
diff --git a/games/vkQuake/fix_minalloc_make.patch b/games/vkQuake/fix_minalloc_make.patch
new file mode 100644
index 000000000000..76fc4eb9742a
--- /dev/null
+++ b/games/vkQuake/fix_minalloc_make.patch
@@ -0,0 +1,49 @@
+From f1a54fbdf403f0b2f54dd89879b82e68d5f08fcf Mon Sep 17 00:00:00 2001
+From: vsonnier <vsonnier@users.noreply.github.com>
+Date: Sat, 22 Jun 2024 17:10:36 +0200
+Subject: [PATCH] Fix compilation missing mimalloc using Make
+
+---
+ Quake/Makefile.w32 | 2 +-
+ Quake/Makefile.w64 | 2 +-
+ Quake/common.make | 1 +
+ 3 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Quake/Makefile.w32 b/Quake/Makefile.w32
+index 38516637..1a3f8ef1 100644
+--- a/Quake/Makefile.w32
++++ b/Quake/Makefile.w32
+@@ -63,7 +63,7 @@ endif
+
+ NET_LIBS := -lws2_32
+
+-CFLAGS += -I../Windows/codecs/include -Imimalloc
++CFLAGS += -I../Windows/codecs/include
+ CODEC_LINK = -L../Windows/codecs/x86
+
+ VK_SDK_PATH ?= ../Windows/misc
+diff --git a/Quake/Makefile.w64 b/Quake/Makefile.w64
+index f8d22eac..8abf4117 100644
+--- a/Quake/Makefile.w64
++++ b/Quake/Makefile.w64
+@@ -57,7 +57,7 @@ endif
+
+ NET_LIBS := -lws2_32
+
+-CFLAGS += -I../Windows/codecs/include -Imimalloc
++CFLAGS += -I../Windows/codecs/include
+ CODEC_LINK = -L../Windows/codecs/x64
+
+ VK_SDK_PATH ?= ../Windows/misc
+diff --git a/Quake/common.make b/Quake/common.make
+index c1d7b61c..f6f970af 100644
+--- a/Quake/common.make
++++ b/Quake/common.make
+@@ -101,6 +101,7 @@ endif
+ ifeq ($(USE_CODEC_UMX),1)
+ CFLAGS += -DUSE_CODEC_UMX
+ endif
++CFLAGS += -Imimalloc
+
+ # ---------------------------
+ # objects
diff --git a/games/vkQuake/vkQuake.SlackBuild b/games/vkQuake/vkQuake.SlackBuild
index b083a5a943cc..d46ac2695bd9 100644
--- a/games/vkQuake/vkQuake.SlackBuild
+++ b/games/vkQuake/vkQuake.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vkQuake
-VERSION=${VERSION:-1.30.1}
+VERSION=${VERSION:-1.31.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -73,6 +73,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/fix_minalloc_make.patch
+
# Clean up Makefiles
make -C Quake clean
diff --git a/games/vkQuake/vkQuake.info b/games/vkQuake/vkQuake.info
index c434fe3f89f2..34e466100d83 100644
--- a/games/vkQuake/vkQuake.info
+++ b/games/vkQuake/vkQuake.info
@@ -1,10 +1,10 @@
PRGNAM="vkQuake"
-VERSION="1.30.1"
+VERSION="1.31.0"
HOMEPAGE="https://github.com/Novum/vkQuake"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/Novum/vkQuake/archive/1.30.1/vkQuake-1.30.1.tar.gz"
-MD5SUM_x86_64="1b7a8536161f1b342850eebcef551eb6"
+DOWNLOAD_x86_64="https://github.com/Novum/vkQuake/archive/1.31.0/vkQuake-1.31.0.tar.gz"
+MD5SUM_x86_64="d6003a08bdab383b6d1e5de12d4c3fee"
REQUIRES="zopfli"
MAINTAINER="M.Dinslage"
EMAIL="matthewdinslage@gmail.com"