aboutsummaryrefslogtreecommitdiff
path: root/games/vkQuake/fix_minalloc_make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/vkQuake/fix_minalloc_make.patch')
-rw-r--r--games/vkQuake/fix_minalloc_make.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/games/vkQuake/fix_minalloc_make.patch b/games/vkQuake/fix_minalloc_make.patch
new file mode 100644
index 000000000000..76fc4eb9742a
--- /dev/null
+++ b/games/vkQuake/fix_minalloc_make.patch
@@ -0,0 +1,49 @@
+From f1a54fbdf403f0b2f54dd89879b82e68d5f08fcf Mon Sep 17 00:00:00 2001
+From: vsonnier <vsonnier@users.noreply.github.com>
+Date: Sat, 22 Jun 2024 17:10:36 +0200
+Subject: [PATCH] Fix compilation missing mimalloc using Make
+
+---
+ Quake/Makefile.w32 | 2 +-
+ Quake/Makefile.w64 | 2 +-
+ Quake/common.make | 1 +
+ 3 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Quake/Makefile.w32 b/Quake/Makefile.w32
+index 38516637..1a3f8ef1 100644
+--- a/Quake/Makefile.w32
++++ b/Quake/Makefile.w32
+@@ -63,7 +63,7 @@ endif
+
+ NET_LIBS := -lws2_32
+
+-CFLAGS += -I../Windows/codecs/include -Imimalloc
++CFLAGS += -I../Windows/codecs/include
+ CODEC_LINK = -L../Windows/codecs/x86
+
+ VK_SDK_PATH ?= ../Windows/misc
+diff --git a/Quake/Makefile.w64 b/Quake/Makefile.w64
+index f8d22eac..8abf4117 100644
+--- a/Quake/Makefile.w64
++++ b/Quake/Makefile.w64
+@@ -57,7 +57,7 @@ endif
+
+ NET_LIBS := -lws2_32
+
+-CFLAGS += -I../Windows/codecs/include -Imimalloc
++CFLAGS += -I../Windows/codecs/include
+ CODEC_LINK = -L../Windows/codecs/x64
+
+ VK_SDK_PATH ?= ../Windows/misc
+diff --git a/Quake/common.make b/Quake/common.make
+index c1d7b61c..f6f970af 100644
+--- a/Quake/common.make
++++ b/Quake/common.make
+@@ -101,6 +101,7 @@ endif
+ ifeq ($(USE_CODEC_UMX),1)
+ CFLAGS += -DUSE_CODEC_UMX
+ endif
++CFLAGS += -Imimalloc
+
+ # ---------------------------
+ # objects