aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2024-02-05 15:10:22 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-07 23:28:30 +0700
commitef71a96b043703a35f32774618e320f36b48967c (patch)
tree99823a9d2f96837e8fcf5882f11cea98db258cbb /python
parent4a63db05139c6f6d598f674fd669bc90572894cd (diff)
python/python3-pytest: Version bump to 8.0.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pytest/python3-pytest.SlackBuild7
-rw-r--r--python/python3-pytest/python3-pytest.info6
2 files changed, 7 insertions, 6 deletions
diff --git a/python/python3-pytest/python3-pytest.SlackBuild b/python/python3-pytest/python3-pytest.SlackBuild
index 71e20b8fd01c1..dd286ea19f6e8 100644
--- a/python/python3-pytest/python3-pytest.SlackBuild
+++ b/python/python3-pytest/python3-pytest.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2018 Serban Udrea <S.Udrea@gsi.de>
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
# Based on the pytest SlackBuild by Dimitris Zlatanidis Orestiada, Greece
#
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pytest
SRCNAM=pytest
-VERSION=${VERSION:-7.4.3}
+VERSION=${VERSION:-8.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
mv $PKG/usr/bin/py.test $PKG/usr/bin/py.test3
mv $PKG/usr/bin/pytest $PKG/usr/bin/pytest3
diff --git a/python/python3-pytest/python3-pytest.info b/python/python3-pytest/python3-pytest.info
index db42465ca058f..43a920b6cb9bc 100644
--- a/python/python3-pytest/python3-pytest.info
+++ b/python/python3-pytest/python3-pytest.info
@@ -1,8 +1,8 @@
PRGNAM="python3-pytest"
-VERSION="7.4.3"
+VERSION="8.0.0"
HOMEPAGE="http://pytest.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pytest/pytest-7.4.3.tar.gz"
-MD5SUM="9a13432f66fd105bdcbca3db867721bc"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pytest/pytest-8.0.0.tar.gz"
+MD5SUM="33171e0864d85ffc89eff6128385a326"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-iniconfig python3-exceptiongroup"