aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pytest/python3-pytest.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pytest/python3-pytest.SlackBuild')
-rw-r--r--python/python3-pytest/python3-pytest.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-pytest/python3-pytest.SlackBuild b/python/python3-pytest/python3-pytest.SlackBuild
index 71e20b8fd01c1..dd286ea19f6e8 100644
--- a/python/python3-pytest/python3-pytest.SlackBuild
+++ b/python/python3-pytest/python3-pytest.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2018 Serban Udrea <S.Udrea@gsi.de>
# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
# Based on the pytest SlackBuild by Dimitris Zlatanidis Orestiada, Greece
#
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pytest
SRCNAM=pytest
-VERSION=${VERSION:-7.4.3}
+VERSION=${VERSION:-8.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
mv $PKG/usr/bin/py.test $PKG/usr/bin/py.test3
mv $PKG/usr/bin/pytest $PKG/usr/bin/pytest3