aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-10-17 12:17:19 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-16 16:41:08 +0700
commit74d9a7424eca4f1073feef0b7dd4121e520f2801 (patch)
treeae8c8126fa6b91e5bb9adb152cbc7fce26ecbaa9 /python
parent2750b43ebc14e5422af3d9fc9729dc931fe7b582 (diff)
python/python3-pyproject-hooks: Updated for version 1.2.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild24
-rw-r--r--python/python3-pyproject-hooks/python3-pyproject-hooks.info6
2 files changed, 8 insertions, 22 deletions
diff --git a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild b/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
index acffa128e7a3..342c1ed67548 100644
--- a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
+++ b/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pyproject-hooks
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-hooks
-SRCNAM=$(echo ${PRGNAM#python3-*} | sed -e "s/-/_/")
-VERSION=${VERSION:-1.0.0}
+SRCNAM=pyproject_hooks
+VERSION=${VERSION:-1.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -73,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 -m flit_core.wheel
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/python/python3-pyproject-hooks/python3-pyproject-hooks.info b/python/python3-pyproject-hooks/python3-pyproject-hooks.info
index 59e5d918ae67..91bbe9f0699c 100644
--- a/python/python3-pyproject-hooks/python3-pyproject-hooks.info
+++ b/python/python3-pyproject-hooks/python3-pyproject-hooks.info
@@ -1,8 +1,8 @@
PRGNAM="python3-pyproject-hooks"
-VERSION="1.0.0"
+VERSION="1.2.0"
HOMEPAGE="https://github.com/pypa/pyproject-hooks"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyproject_hooks/pyproject_hooks-1.0.0.tar.gz"
-MD5SUM="69b0b6de189bc04c3f9e304281765741"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pyproject_hooks/pyproject_hooks-1.2.0.tar.gz"
+MD5SUM="ed3dd1b984339e83e35f676d7169c192"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-installer"