aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild')
-rw-r--r--python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild24
1 files changed, 5 insertions, 19 deletions
diff --git a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild b/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
index acffa128e7..342c1ed675 100644
--- a/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
+++ b/python/python3-pyproject-hooks/python3-pyproject-hooks.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pyproject-hooks
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-hooks
-SRCNAM=$(echo ${PRGNAM#python3-*} | sed -e "s/-/_/")
-VERSION=${VERSION:-1.0.0}
+SRCNAM=pyproject_hooks
+VERSION=${VERSION:-1.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -73,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 -m flit_core.wheel
python3 -m installer -d "$PKG" dist/*.whl