aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter@wuille.net>2023-06-30 00:30:34 -0400
committerPieter Wuille <pieter@wuille.net>2023-07-26 16:55:00 -0400
commit9ff0768bdcca06836ccc673eacfa648e801930cb (patch)
treed97a2ecfc83c0b889f0692921cc3b50febd39798 /src/Makefile.am
parent9fd085a1a49d317abcaf1492b71c48bf1a1b3007 (diff)
downloadbitcoin-9ff0768bdcca06836ccc673eacfa648e801930cb.tar.xz
crypto: add the ChaCha20Poly1305 AEAD as specified in RFC8439
This adds an implementation of the ChaCha20Poly1305 AEAD exactly matching the version specified in RFC8439 section 2.8, including tests and official test vectors.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8ea4bbd28..b6fe256335 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -548,6 +548,8 @@ crypto_libbitcoin_crypto_base_la_SOURCES = \
crypto/aes.h \
crypto/chacha20.h \
crypto/chacha20.cpp \
+ crypto/chacha20poly1305.h \
+ crypto/chacha20poly1305.cpp \
crypto/common.h \
crypto/hkdf_sha256_32.cpp \
crypto/hkdf_sha256_32.h \