aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter@wuille.net>2023-06-28 14:09:53 -0400
committerPieter Wuille <pieter@wuille.net>2023-07-26 16:51:51 -0400
commit9fd085a1a49d317abcaf1492b71c48bf1a1b3007 (patch)
tree411e70c5695ca7380ea0dc1bad3cbff2ea0e2ae4 /src/Makefile.am
parentf57e724a809feb139c5ae71c4db65635427e4802 (diff)
downloadbitcoin-9fd085a1a49d317abcaf1492b71c48bf1a1b3007.tar.xz
crypto: remove outdated variant of ChaCha20Poly1305 AEAD
Remove the variant of ChaCha20Poly1305 AEAD that was previously added in anticipation of BIP324 using it. BIP324 was updated to instead use rekeying wrappers around otherwise unmodified versions of the ChaCha20 stream cipher and the ChaCha20Poly1305 AEAD as specified in RFC8439.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dfea7146aa..d8ea4bbd28 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -546,8 +546,6 @@ crypto_libbitcoin_crypto_base_la_LDFLAGS = $(AM_LDFLAGS) -static
crypto_libbitcoin_crypto_base_la_SOURCES = \
crypto/aes.cpp \
crypto/aes.h \
- crypto/chacha_poly_aead.h \
- crypto/chacha_poly_aead.cpp \
crypto/chacha20.h \
crypto/chacha20.cpp \
crypto/common.h \