aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2024-02-19 15:31:00 +0000
committerfanquake <fanquake@gmail.com>2024-02-19 15:31:06 +0000
commita4690485d145bef4e4dc9688291aa956a246fd47 (patch)
treee448e0dfdd1f9bb006b2159a6ec20eaa0b1b7f35 /configure.ac
parent74df372750ceb4ccdfe310e18f14cdd3abac4a51 (diff)
parent1e7fb270d36310efff6fc968f1c52291043d461b (diff)
Merge bitcoin/bitcoin#29440: [26.1] final changes for 26.1rc1v26.1rc1
1e7fb270d36310efff6fc968f1c52291043d461b [doc] add release notes for 26.1rc1 (glozow) 0ffeaf237afa337e582cc54984d90cdf12c372d1 [doc] update manual pages for 26.1rc1 (glozow) d4aeb4a5a0426e97eb4bd3240a97e8691800e030 [build] bump version to 26.1rc1 (glozow) c27793891a54376d1eb927c4315c9b47b3af3840 qt: 26.1rc1 translations update (Hennadii Stepanov) 40e7693fa10d8859c1754d2efa4463345d236c81 ci: Switch native macOS CI job to Xcode 15.0 (Hennadii Stepanov) 72eab1ca64071efde811e0b3886dcf253c6780d2 build: Fix `-Xclang -internal-isystem` option (Hennadii Stepanov) Pull request description: Final changes to tag a 26.1rc1. Bumps version numbers, man pages, adds release notes etc. ACKs for top commit: hebasto: re-ACK 1e7fb270d36310efff6fc968f1c52291043d461b fanquake: ACK 1e7fb270d36310efff6fc968f1c52291043d461b Tree-SHA512: 0f4146590d61f4f9322f3147f672ff2af48fc1d85c708b959adcbdb50b8f280570cb732d9f4a424c014046d07e9aa6e408fc3a0337dbaf8cbaea5283697da35a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 01636ab872..472372a6ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,8 @@
AC_PREREQ([2.69])
define(_CLIENT_VERSION_MAJOR, 26)
-define(_CLIENT_VERSION_MINOR, 0)
+define(_CLIENT_VERSION_MINOR, 1)
define(_CLIENT_VERSION_BUILD, 0)
-define(_CLIENT_VERSION_RC, 0)
+define(_CLIENT_VERSION_RC, 1)
define(_CLIENT_VERSION_IS_RELEASE, true)
define(_COPYRIGHT_YEAR, 2023)
define(_COPYRIGHT_HOLDERS,[The %s developers])
@@ -755,7 +755,7 @@ case $host in
dnl option to system-ify all /usr/local/include paths without adding it to the list
dnl of search paths in case it's not already there.
if test "$suppress_external_warnings" != "no"; then
- AX_CHECK_PREPROC_FLAG([-Xclang -internal-isystem/usr/local/include], [CORE_CPPFLAGS="$CORE_CPPFLAGS -Xclang -internal-isystem/usr/local/include"], [], [$CXXFLAG_WERROR])
+ AX_CHECK_PREPROC_FLAG([-Xclang -internal-isystem -Xclang /usr/local/include/], [CORE_CPPFLAGS="$CORE_CPPFLAGS -Xclang -internal-isystem -Xclang /usr/local/include/"], [], [$CXXFLAG_WERROR])
fi
if test "$use_bdb" != "no" && $BREW list --versions berkeley-db@4 >/dev/null && test "$BDB_CFLAGS" = "" && test "$BDB_LIBS" = ""; then