aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-12-13 14:21:58 +0000
committerfanquake <fanquake@gmail.com>2023-12-13 14:32:00 +0000
commit0830dcb3131d2fd5562f5d3c407b44bc639c78c9 (patch)
tree504dde02b1962845f899f72ac5bab82df798a652 /configure.ac
parentf0e829022a415c7c9513e715c532079ec7756306 (diff)
parent49a90915aa3ee8e3a7e163f23a55de931faf8523 (diff)
downloadbitcoin-0830dcb3131d2fd5562f5d3c407b44bc639c78c9.tar.xz
Merge bitcoin/bitcoin#29066: Bump minimum required Boost version due to migration to C++20
49a90915aa3ee8e3a7e163f23a55de931faf8523 build: Bump minimum required Boost to 1.73.0 to support C++20 (Hennadii Stepanov) Pull request description: Boost versions <1.73 have C++20-specific bugs that were fixed in the following commits: - https://github.com/boostorg/signals2/commit/15fcf213563718d2378b6b83a1614680a4fa8cec - https://github.com/boostorg/test/commit/495c095dc063052ce54f2fe9217fe0fc69ced5f1 I tested [`libboost1.71-dev`](https://packages.ubuntu.com/focal/libboost1.71-dev) in Ubuntu 20.04 and Boost 1.71, 1.72, 1.73 in our depends build system. Closes https://github.com/bitcoin/bitcoin/issues/29063. ACKs for top commit: fanquake: ACK 49a90915aa3ee8e3a7e163f23a55de931faf8523 Tree-SHA512: b8ebc08af85abfa3fda70961bd1136ee9e5149dd76a3f901e43acba624d231971873cba5cbf30837f9e5ab58790b8330f241a76cb76d8cf5dce5ad0cca33fba8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 18b00a2b16..7b286df603 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1454,7 +1454,7 @@ fi
if test "$use_boost" = "yes"; then
dnl Check for Boost headers
- AX_BOOST_BASE([1.64.0],[],[AC_MSG_ERROR([Boost is not available!])])
+ AX_BOOST_BASE([1.73.0],[],[AC_MSG_ERROR([Boost is not available!])])
if test "$want_boost" = "no"; then
AC_MSG_ERROR([only libbitcoinconsensus can be built without Boost])
fi