aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2023-12-12 19:38:55 +0000
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2023-12-12 19:59:52 +0000
commit49a90915aa3ee8e3a7e163f23a55de931faf8523 (patch)
tree45ee21907484dbcd530acd8f8a933ced7d72a4e5 /configure.ac
parentd646ca35d991e4f694096fdbd2d2ebd8cebf244e (diff)
downloadbitcoin-49a90915aa3ee8e3a7e163f23a55de931faf8523.tar.xz
build: Bump minimum required Boost to 1.73.0 to support C++20
Boost versions <1.73 have C++20-specific bugs that were fixed in the following commits: - https://github.com/boostorg/signals2/commit/15fcf213563718d2378b6b83a1614680a4fa8cec - https://github.com/boostorg/test/commit/495c095dc063052ce54f2fe9217fe0fc69ced5f1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 58235d67c6..dcf4f10426 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1454,7 +1454,7 @@ fi
if test "$use_boost" = "yes"; then
dnl Check for Boost headers
- AX_BOOST_BASE([1.64.0],[],[AC_MSG_ERROR([Boost is not available!])])
+ AX_BOOST_BASE([1.73.0],[],[AC_MSG_ERROR([Boost is not available!])])
if test "$want_boost" = "no"; then
AC_MSG_ERROR([only libbitcoinconsensus can be built without Boost])
fi