aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-04-29 21:10:22 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:40 +0100
commitae7b39a0e106d798b6e9cc03ee783d9081e41480 (patch)
tree7abf4e117f43bc90345aa6774c20be555281bdea /CMakeLists.txt
parent6480e1dcdb03f43ce3d0aad96b8668d017d11750 (diff)
downloadbitcoin-ae7b39a0e106d798b6e9cc03ee783d9081e41480.tar.xz
cmake: Add `libminiupnpc` optional package support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c798c2e01f..d13909a673 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,6 +111,11 @@ if(WITH_NATPMP)
find_package(NATPMP MODULE REQUIRED)
endif()
+option(WITH_MINIUPNPC "Enable UPnP." OFF)
+if(WITH_MINIUPNPC)
+ find_package(MiniUPnPc MODULE REQUIRED)
+endif()
+
set(configure_warnings)
include(CheckPIESupported)
@@ -285,6 +290,7 @@ if(ENABLE_WALLET)
endif()
message(" port mapping:")
message(" - using NAT-PMP .................... ${WITH_NATPMP}")
+message(" - using UPnP ....................... ${WITH_MINIUPNPC}")
message("Tests:")
message(" test_bitcoin ........................ ${BUILD_TESTS}")
message("")