aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-06-04 13:44:32 +0100
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:40 +0100
commit6480e1dcdb03f43ce3d0aad96b8668d017d11750 (patch)
tree57683d60ae5a68c54d089694587d2827cddd778d /CMakeLists.txt
parente73e9304a11af65f9b086460ff349f9f700709ce (diff)
downloadbitcoin-6480e1dcdb03f43ce3d0aad96b8668d017d11750.tar.xz
cmake: Add `libnatpmp` optional package support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 035a8e43ab..c798c2e01f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,6 +106,11 @@ cmake_dependent_option(BUILD_WALLET_TOOL "Build bitcoin-wallet tool." ${BUILD_TE
option(WITH_CCACHE "Attempt to use ccache for compiling." ON)
+option(WITH_NATPMP "Enable NAT-PMP." OFF)
+if(WITH_NATPMP)
+ find_package(NATPMP MODULE REQUIRED)
+endif()
+
set(configure_warnings)
include(CheckPIESupported)
@@ -278,6 +283,8 @@ if(ENABLE_WALLET)
message(" - descriptor wallets (SQLite) ...... ${WITH_SQLITE}")
message(" - legacy wallets (Berkeley DB) ..... ${WITH_BDB}")
endif()
+message(" port mapping:")
+message(" - using NAT-PMP .................... ${WITH_NATPMP}")
message("Tests:")
message(" test_bitcoin ........................ ${BUILD_TESTS}")
message("")