aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCory Fields <theuni-nospam-@xbmc.org>2012-08-14 18:02:57 -0400
committerCory Fields <theuni-nospam-@xbmc.org>2012-08-14 18:52:28 -0400
commit9b0cd92c1cbfbff88385c9e5cb456506f35c0487 (patch)
treeca554379f39ccabefe7547649150b8b50f26ace1 /configure.in
parentc0214429c1ffd75dd5832c77cf3a4f6e6cc23c6f (diff)
build: fix ffmpeg soname and busted build target
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 46095cad08..a0fd2c56f9 100644
--- a/configure.in
+++ b/configure.in
@@ -2396,8 +2396,8 @@ XB_CONFIG_MODULE([lib/ffmpeg], [
--enable-pthreads \
--enable-runtime-cpudetect \
`if test "$target_platform" = "target_android" && test "$host_cpu" = "i686"; then echo --disable-mmx; fi #workaround for gcc 4.6 bug` \
- `if test "$target_platform" = "target_android"; then echo '--custom-libname-with-major="\$(SLIBPREF)\$(FULLNAME)-\$(LIBMAJOR)-${ARCH}\$(SLIBSUF)"'; \
- else echo '--custom-libname-with-major="\$(FULLNAME)-\$(LIBMAJOR)-${ARCH}\$(SLIBSUF)"'; fi` \
+ `if test "$target_platform" = "target_android"; then echo "--custom-libname-with-major=\\$(SLIBPREF)\\$(FULLNAME)-\\$(LIBMAJOR)-${ARCH}\\$(SLIBSUF)"; \
+ else echo "--custom-libname-with-major=\\$(FULLNAME)-\\$(LIBMAJOR)-${ARCH}\\$(SLIBSUF)"; fi` \
`case $host_cpu in i?86*) echo --disable-pic ;; *) echo --enable-pic ;; esac` \
--cc="$CC" &&
sed -i -e "s#define HAVE_SYMVER 1#define HAVE_SYMVER 0#" config.h &&