aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordavilla <davilla@4pi.com>2012-12-14 12:01:37 -0500
committerdavilla <davilla@4pi.com>2012-12-14 12:01:37 -0500
commit843d81c787284e3ab2bcb081c7156e6f3143ce23 (patch)
tree01a0560313f583eddfe2e2da2ac742f82e3b6b99 /configure.in
parentd420cf685f2169f40c0edb9919d33d845ed15e87 (diff)
Revert "fix configure warnings when lame lib exists but not the headers (closes #13647)"
This reverts commit 2f4a1868897a797b69b9d2795177d6c62b3e3ba0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 5 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index f760971b67..4db7fdef20 100644
--- a/configure.in
+++ b/configure.in
@@ -1078,16 +1078,11 @@ XB_FIND_SONAME([ASS], [ass])
XB_FIND_SONAME([MPEG2], [mpeg2])
# Audio encoders
-if test "x$use_libmp3lame" = "xyes"; then
- AC_CHECK_HEADER([lame/lame.h],
- [XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])],
- AC_MSG_ERROR(lame/lame.h not found)
- )
-elif test "x$use_libmp3lame" != "xno"; then
- AC_CHECK_HEADER([lame/lame.h],
- [XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])],
- AC_MSG_NOTICE(lame/lame.h not found)
- )
+if test "x$use_libmp3lame" != "xno"; then
+ XB_FIND_SONAME([LAMEENC], [mp3lame], [use_libmp3lame])
+ if test "x$use_libmp3lame" != "xno"; then
+ AC_CHECK_HEADER([lame/lame.h],, AC_MSG_ERROR($missing_headers))
+ fi
fi
AS_CASE([x$use_libmp3lame],
[xno],[