aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorceros7 <ceros7@svn>2010-08-01 02:48:38 +0000
committerceros7 <ceros7@svn>2010-08-01 02:48:38 +0000
commit159abfb9c1278dc33ac6d1f9bf772843cbf59f3b (patch)
treec4aa5bab93cd17dd12c8ff15c544a86bac997eac /configure.in
parent813e7ebb11f2f74d6a3ce9c46c7d08c7eff2530d (diff)
Don't do anything with XB_CONFIG_MODULE when not building for apple host.
This allows removing directory with third party code from sources. git-svn-id: https://xbmc.svn.sourceforge.net/svnroot/xbmc/trunk@32383 568bbfeb-2a22-0410-94d2-cc84cf5bfa90
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 12 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index c30896863a..7fac91c39e 100644
--- a/configure.in
+++ b/configure.in
@@ -639,6 +639,12 @@ else
AC_MSG_ERROR($missing_library))
fi
+# This is used to skip some submodule configuration on non-Apple hardware
+HOST_NOT_APPLE=1
+if [[ "$host_vendor" = "apple" ]]; then
+ HOST_NOT_APPLE=0
+fi
+
# check for library basenames
AC_DEFUN([XB_FIND_SONAME],
[
@@ -1582,10 +1588,8 @@ XB_CONFIG_MODULE([xbmc/cores/paplayer/FLACCodec/flac-1.2.1], [
--disable-cpplibs \
CC="$CC" \
CXX="$CXX"
- else
- true
fi
-], [0])
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/ffmpeg], [
if test "$host_vendor" = "apple" ; then
@@ -1753,10 +1757,8 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/libfaad2], [
CFLAGS="$CFLAGS -O3 -fno-common" \
./configure MACOSX_DEPLOYMENT_TARGET=10.4 \
--with-pic
- else
- true
fi
-], [0])
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/liba52], [
if test "$host_vendor" = "apple" ; then
@@ -1790,10 +1792,8 @@ XB_CONFIG_MODULE([xbmc/cores/dvdplayer/Codecs/libmad], [
CFLAGS="$CFLAGS -fno-common" \
./configure MACOSX_DEPLOYMENT_TARGET=10.4 \
--with-pic
- else
- true
fi
-], 0)
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([xbmc/lib/cximage-6.0/zlib], [
if test "$host_vendor" = "apple" ; then
@@ -1801,7 +1801,7 @@ XB_CONFIG_MODULE([xbmc/lib/cximage-6.0/zlib], [
CFLAGS="$CFLAGS -fno-common" \
./configure
fi
-], [0])
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([lib/libass], [
if test "$host_vendor" = "apple" ; then
@@ -1923,20 +1923,16 @@ XB_CONFIG_MODULE([lib/libmodplug], [
CFLAGS="$CFLAGS -fno-common" \
CXXFLAGS="$CXXFLAGS -fno-common" \
./configure MACOSX_DEPLOYMENT_TARGET=10.4 --with-pic --disable-shared --enable-static
- else
- true
fi
-], [0])
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([lib/libmicrohttpd], [
if test "$host_vendor" = "apple" ; then
CFLAGS="$CFLAGS -fno-common" \
CXXFLAGS="$CXXFLAGS -fno-common" \
./configure MACOSX_DEPLOYMENT_TARGET=10.4 --with-pic --disable-shared --enable-static
- else
- true
fi
-], [0])
+], [$HOST_NOT_APPLE])
XB_CONFIG_MODULE([lib/cpluff], [
if test "$host_vendor" = "apple" ; then