aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMemphiz <memphis@machzwo.de>2016-09-16 16:56:30 +0200
committerMemphiz <memphis@machzwo.de>2016-09-16 16:56:30 +0200
commit2f9b536bd2dd92aafe3d94d2b741c08c0ccf2709 (patch)
treeeb73291dafde2f948ae4b0ec0fe6a50f54a0b2ee /configure.ac
parent563874ca7b66d960caba494a3c0cfd06d4403e81 (diff)
[configure] - define HAVE_SSE and HAVE_SSE2 on osx when compiler says so
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index daec619531..2963beeee1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -762,6 +762,21 @@ if test "$host_vendor" = "apple" ; then
# standard application paths
INCLUDES="$INCLUDES -I\$(abs_top_srcdir)/xbmc/osx"
if test "$use_arch" != "arm"; then
+ SAVE_CFLAGS="$CFLAGS"
+ CFLAGS="-msse -msse2"
+ AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE([int foo;])],
+ [ HAVE_SSE=1
+ HAVE_SSE2=1
+ AC_DEFINE([HAVE_SSE],[1],[sse enabled])
+ AC_DEFINE([HAVE_SSE2],[1],[sse2 enabled])],
+ [ HAVE_SSE=0
+ HAVE_SSE2=0
+ AC_DEFINE([HAVE_SSE],[0],[sse enabled])
+ AC_DEFINE([HAVE_SSE2],[0],[sse2 enabled])
+ ])
+ CFLAGS="$SAVE_CFLAGS"
+
LIBS="$LIBS -framework ApplicationServices"
LIBS="$LIBS -framework AudioUnit"
LIBS="$LIBS -framework AudioToolbox"