aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Rusak <lorusak@gmail.com>2021-12-18 13:07:05 -0800
committerGitHub <noreply@github.com>2021-12-18 13:07:05 -0800
commitf5668b7132c56b360dd41d7ffb844f94f2526d90 (patch)
tree07b5d0a7ad5a0ef3c2c79401b24e829fdcf82ee4 /CMakeLists.txt
parent7609f5cc33c0e9b9163f98387f8cc6548e8aeac1 (diff)
parente163e62ac392446596580d072f81fb6b84752938 (diff)
Merge pull request #20665 from lrusak/werror-changes
[cmake] use -Werror for double-promotion, missing-field-initializers, and sign-compare
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6faacb7e6c..447d08f589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,6 +251,10 @@ set_target_properties(compileinfo PROPERTIES FOLDER "Build Utilities")
target_compile_options(compileinfo PRIVATE "${SYSTEM_DEFINES} ${ARCH_DEFINES}")
add_dependencies(compileinfo fmt)
+if(NOT MSVC)
+ target_compile_options(compileinfo PUBLIC ${CORE_COMPILE_OPTIONS})
+endif()
+
# RC File
if(WIN32)
configure_file(${CMAKE_SOURCE_DIR}/xbmc/platform/win32/XBMC_PC.rc.in