aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVasyl Gello <vasek.gello@gmail.com>2021-10-31 14:32:56 +0000
committerVasyl Gello <vasek.gello@gmail.com>2021-11-03 15:51:23 +0000
commite864302e870b75dd34a2c4d0dc217f4b920fb30e (patch)
treebd263d632355a70bc1dcb559b968c6214a4c855b /CMakeLists.txt
parent105de4bf4872c95229c3d605bc83ce61707af58c (diff)
Split TexturePacker executed during build and shipped
Before this commit, shippable TexturePacker is not built at all if: * the pre-built TexturePacker is supplied by -DWITH_TEXTUREPACKER * build is KODI_DEPENDSBUILD * building for Windows This breaks generation of kodi-tools-texturepacker package on Linux and FreeBSD if cross-compiling. The new commit separates installable and executable TexturePackers. Executable TexturePacker is executed on all platforms, but it can be overriden by a binary specified by KODI_DEPENDSBUILD or WITH_TEXTUREPACKER options on non-depends build. Installable TexturePacker is shipped only on Linux and FreeBSD platforms, and is executed only if the build is not a cross-compilation and the executable TexturePacker not overridden by one of the options above. If external TexturePacker is specified WITH_TEXTUREPACKER but its executable file can not be found, a warning is raised and the module falls back to build internal TexturePacker if it can be executed during the build. Signed-off-by: Vasyl Gello <vasek.gello@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e46f87255..0314ee42a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -289,7 +289,7 @@ foreach(skin ${SKINS})
endforeach()
add_custom_target(pack-skins ALL
- DEPENDS TexturePacker::TexturePacker export-files ${XBT_FILES})
+ DEPENDS TexturePacker::TexturePacker::Executable export-files ${XBT_FILES})
set_target_properties(pack-skins PROPERTIES FOLDER "Build Utilities")
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/system/players/VideoPlayer)