aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2022-03-23 19:50:07 +1000
committerfuzzard <fuzzard@kodi.tv>2022-03-26 14:15:12 +1000
commite4e02a33e4fea6ad807451e5d4704d443d439b95 (patch)
treea3384364250f5d9b05a7c55c712852f6cb83e7f4 /CMakeLists.txt
parent30487801f7bd2a337a4bc904bbb7e8381483f3be (diff)
[cmake] ENABLE_INTERNAL_RapidJSON for all platforms
header only lib, so enable "build" for all platforms patches remove superfluous docs/examples win arm64 patch for endian define.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db9f62dc4b..e4653d8a97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,9 +59,10 @@ option(ENABLE_TESTING "Enable testing support?" ON)
option(ENABLE_INTERNAL_CROSSGUID "Enable internal crossguid?" ON)
# use ffmpeg from depends or system
option(ENABLE_INTERNAL_FFMPEG "Enable internal ffmpeg?" OFF)
+option(ENABLE_INTERNAL_RapidJSON "Enable internal rapidjson?" ON)
+
if(UNIX)
option(FFMPEG_PATH "Path to external ffmpeg?" "")
- option(ENABLE_INTERNAL_RapidJSON "Enable internal rapidjson?" OFF)
option(ENABLE_INTERNAL_FMT "Enable internal fmt?" OFF)
option(ENABLE_INTERNAL_FSTRCMP "Enable internal fstrcmp?" OFF)
option(ENABLE_INTERNAL_FLATBUFFERS "Enable internal flatbuffers?" OFF)