aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2024-05-17 22:37:49 +1000
committerfuzzard <fuzzard@kodi.tv>2024-06-22 14:06:06 +1000
commitbad07bc815eb04a74f21cc769f5eb84ce8d03256 (patch)
tree31c5c089bae9ce2f5d87ffb90452ad62c843ae39 /CMakeLists.txt
parentf68df145d1b8be7a0973a19a70cc1cea7379ee5f (diff)
[cmake] Document some variables and their expected usage
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99bce671ab..9a4e4da831 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -418,6 +418,9 @@ core_add_subdirs_from_filelist(${CMAKE_SOURCE_DIR}/cmake/treedata/common/*.txt
core_add_optional_subdirs_from_filelist(${CMAKE_SOURCE_DIR}/cmake/treedata/optional/common/*.txt
${CMAKE_SOURCE_DIR}/cmake/treedata/optional/${CORE_SYSTEM_NAME}/*.txt)
+# core_DEPENDS: these are the artifact/object files of /xbmc/*
+# SYSTEM_LDFLAGS: system linker flags
+# DEPLIBS: system libraries for linking
target_link_libraries(lib${APP_NAME_LC} PUBLIC ${core_DEPENDS} ${SYSTEM_LDFLAGS} ${DEPLIBS} ${CMAKE_DL_LIBS})
core_target_link_libraries(lib${APP_NAME_LC})
set_target_properties(lib${APP_NAME_LC} PROPERTIES PROJECT_LABEL "xbmc")