aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRechi <Rechi@users.noreply.github.com>2018-11-04 22:48:54 +0100
committerRechi <Rechi@users.noreply.github.com>2018-11-04 22:48:54 +0100
commita677cb0ec2f9308d431fa3a13f64347301e7f225 (patch)
tree439bd90d29a6afd7c5a75c74adfa453aba525792 /CMakeLists.txt
parentadaa8b3bff11a932b4d8c4518a4310997199db03 (diff)
[cmake] fix building with internal libs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d297716029..28024af9fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -293,9 +293,11 @@ elseif(CORE_SYSTEM_NAME STREQUAL android)
${CORE_BUILD_DIR}/DllPaths_generated_android.h @ONLY)
endif()
+set(GLOBAL_TARGET_DEPS libcpluff ffmpeg dvdnav crossguid fmt fstrcmp flatbuffers ${PLATFORM_GLOBAL_TARGET_DEPS})
+
# main library (used for main binary and tests)
add_library(lib${APP_NAME_LC} STATIC $<TARGET_OBJECTS:compileinfo>)
-add_dependencies(lib${APP_NAME_LC} libcpluff ffmpeg dvdnav crossguid fmt fstrcmp flatbuffers ${PLATFORM_GLOBAL_TARGET_DEPS})
+add_dependencies(lib${APP_NAME_LC} ${GLOBAL_TARGET_DEPS})
set_target_properties(lib${APP_NAME_LC} PROPERTIES PREFIX "")
# Other files (IDE)