aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2022-03-27 14:44:47 +1000
committerfuzzard <fuzzard@kodi.tv>2023-08-09 15:50:50 +1000
commit9e983ed0449aaf3007d8bfa3261056b120d84188 (patch)
tree3d0fe217f9bb79e598fbc641af23698761d6d643 /CMakeLists.txt
parentbe5b014bc5d63cf94d0fad6b9b24dcfe2bef7679 (diff)
Implement TinyXML2 to replace TinyXML1
cmake: add FindTinyXML2 find module cmake: enable building tinyxml2 for all platforms (ENABLE_INTERNAL_TINYXML2) tests: Tests for XBMCTinyXML2 implementation tests: Tests for XMLUtils for the tinyxml2 methods utils: implement TinyXML2 methods for XMLUtils Currently tinyxml2 and 1 can coexist peacefully. This will allow a staged replacement and to hopefully update and implement tests appropriately.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c06939bf69..60a6803327 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -188,6 +188,7 @@ set(required_deps ASS
Sqlite3
TagLib
TinyXML
+ TinyXML2
ZLIB
${PLATFORM_REQUIRED_DEPS})