aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRainer Hochecker <fernetmenta@online.de>2018-04-11 16:59:20 +0200
committerRainer Hochecker <fernetmenta@online.de>2018-04-15 10:36:38 +0200
commit6e156bea5bf3a7fb8967e888238b6a07b967a90b (patch)
tree6379746926ecc797613a9dc31f274a7598082325 /CMakeLists.txt
parente0b81f6419c3fef546c89267b691216c778332fb (diff)
lirc: redesign
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1aafc21a54..18568cd550 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,7 +64,6 @@ if(NOT WIN32)
option(WITH_CPU "build with given cpu" OFF)
endif()
if(CORE_SYSTEM_NAME STREQUAL linux)
- option(ENABLE_LIRC "Enable LIRC support?" ON)
option(ENABLE_EVENTCLIENTS "Enable event clients support?" OFF)
endif()
@@ -149,6 +148,7 @@ set(optional_deps Alsa
CCache
DBus
LCMS2
+ LircClient
MDNS
MicroHttpd
PulseAudio
@@ -201,11 +201,6 @@ if(ENABLE_OPTICAL)
list(APPEND DEP_DEFINES -DHAS_DVD_DRIVE -DHAS_CDDA_RIPPER)
endif()
-if(ENABLE_LIRC)
- set(LIRC_DEVICE /dev/lircd CACHE STRING "LIRC device to use")
- list(APPEND DEP_DEFINES -DLIRC_DEVICE="${LIRC_DEVICE}" -DHAS_LIRC=1)
-endif()
-
if(ENABLE_AIRTUNES)
find_package(Shairplay)
if(SHAIRPLAY_FOUND)