aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfuzzard <fuzzard@kodi.tv>2024-05-16 13:14:45 +1000
committerfuzzard <fuzzard@kodi.tv>2024-06-22 14:06:06 +1000
commit5a35fb7cf8fb4bbd23a0fb85fb6c2fafec5d2066 (patch)
treed00b476c4ab90f2b3d626101174d488b0cd69af1 /CMakeLists.txt
parent83c2599107e3855e28b83ac0a590593f266dc901 (diff)
[cmake] Enable CMP0079
https://cmake.org/cmake/help/latest/policy/CMP0079.html This allows using target_link_libraries to a target not in the same calling directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 635b7b5218..18c3bc2977 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ if(POLICY CMP0069)
cmake_policy(SET CMP0069 NEW)
endif()
+if(POLICY CMP0079)
+ set(CMAKE_POLICY_DEFAULT_CMP0079 NEW)
+ cmake_policy(SET CMP0079 NEW)
+endif()
+
if(POLICY CMP0135)
set(CMAKE_POLICY_DEFAULT_CMP0135 NEW)
cmake_policy(SET CMP0135 NEW)