aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Rusak <lorusak@gmail.com>2020-04-15 17:07:37 -0700
committerLukas Rusak <lorusak@gmail.com>2021-12-29 19:01:45 -0800
commit1581b7c8ae6096c753cfb1401f91789603d16743 (patch)
tree908f8d8d970b68a9cae8b85ddce871fc7952673d /CMakeLists.txt
parente50b43d01a3bd2bfe880b99d962008b087ab8635 (diff)
[cmake] add targets for cppcheck and clang-tidy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 447d08f589..534e8e29f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -416,6 +416,8 @@ if(CORE_HOST_IS_TARGET AND ENABLE_TESTING)
-DCMAKE_BINARY_DIR=${CMAKE_BINARY_DIR})
set_target_properties(check-commits PROPERTIES FOLDER "Build Utilities")
+ include(${CMAKE_SOURCE_DIR}/cmake/scripts/common/StaticAnalysis.cmake)
+
# code coverage
if(CMAKE_BUILD_TYPE STREQUAL Coverage)
if(EXISTS ${CMAKE_SOURCE_DIR}/cmake/scripts/${CORE_SYSTEM_NAME}/CodeCoverage.cmake)