aboutsummaryrefslogtreecommitdiff
path: root/packages/demobank-ui/Makefile
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2023-06-21 09:44:02 +0200
committerFlorian Dold <florian@dold.me>2023-06-21 09:44:02 +0200
commit709adb2d48c8e3c393d2ebfe2482b9947cd2c1e9 (patch)
tree47df9120b663a01c2d83ab90e5c6a7a9675ef206 /packages/demobank-ui/Makefile
parenta0e0c5c4a61329886b22e11ccac7626d8861bf79 (diff)
downloadwallet-core-709adb2d48c8e3c393d2ebfe2482b9947cd2c1e9.tar.xz
repo: fix Makefiles / top-level 'make install' target
Diffstat (limited to 'packages/demobank-ui/Makefile')
-rw-r--r--packages/demobank-ui/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/packages/demobank-ui/Makefile b/packages/demobank-ui/Makefile
index 11a71f589..fc570b270 100644
--- a/packages/demobank-ui/Makefile
+++ b/packages/demobank-ui/Makefile
@@ -1,17 +1,35 @@
# This Makefile has been placed in the public domain
-# Settings from "./configure"
-include .config.mk
+ifeq ($(TOPLEVEL), yes)
+ $(info top-level build)
+ -include ../../.config.mk
+else
+ $(info package-level build)
+ -include ../../.config.mk
+ -include .config.mk
+endif
+$(info prefix is $(prefix))
+
+.PHONY: all
all:
@echo run \'make install\' to install
spa_dir=$(prefix)/share/taler/demobank-ui
-install:
+.PHONY: deps
+deps:
pnpm install --frozen-lockfile --filter @gnu-taler/demobank-ui...
pnpm run check
pnpm run build
+
+.PHONY: install-nodeps
+install-nodeps:
install -d $(spa_dir)
install ./dist/prod/* $(spa_dir)
+.PHONY: install
+install:
+ $(MAKE) deps
+ $(MAKE) install-nodeps
+