aboutsummaryrefslogtreecommitdiff
path: root/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-11-09 23:14:44 +0100
committerFlorian Dold <florian@dold.me>2021-11-09 23:14:44 +0100
commit77070f9f7467feffaca1bee6a7ab141189568b55 (patch)
treecefb2602b1d51dac514530ec38a1337d100d3ea6 /packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
parent877117748de540896e6cc6a8192f8fe849a1935f (diff)
downloadwallet-core-77070f9f7467feffaca1bee6a7ab141189568b55.tar.xz
anastasis-webui: fix telephone input
Diffstat (limited to 'packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx')
-rw-r--r--packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx b/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
index 86a2f08ee..557718458 100644
--- a/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
+++ b/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
@@ -3,7 +3,7 @@ import { isAfter, parse } from "date-fns";
import { h, VNode } from "preact";
import { useState } from "preact/hooks";
import { DateInput } from "../../components/fields/DateInput";
-import { NumberInput } from "../../components/fields/NumberInput";
+import { PhoneNumberInput } from "../../components/fields/NumberInput";
import { TextInput } from "../../components/fields/TextInput";
import { useAnastasisContext } from "../../context/anastasis";
import { AnastasisClientFrame, withProcessLabel } from "./index";
@@ -95,7 +95,7 @@ function AttributeEntryField(props: AttributeEntryFieldProps): VNode {
bind={[props.value, props.setValue]}
/>}
{props.spec.type === 'number' &&
- <NumberInput
+ <PhoneNumberInput
grabFocus={props.isFirst}
label={props.spec.label}
error={props.errorMessage}