aboutsummaryrefslogtreecommitdiff
path: root/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
diff options
context:
space:
mode:
authorSebastian <sebasjm@gmail.com>2022-01-24 16:47:37 -0300
committerSebastian <sebasjm@gmail.com>2022-01-24 16:52:41 -0300
commit1374b37d2650ab428c9c2b07422afd6083697dfd (patch)
treeb20eb62a725e3664783e5371cbf63f3a3dd420a5 /packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
parent171d070a83c93082026c9e757f7520139ec655c9 (diff)
downloadwallet-core-1374b37d2650ab428c9c2b07422afd6083697dfd.tar.xz
some fixes: #7095 #7080 #7085 #7081 #7089 #7097
Diffstat (limited to 'packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx')
-rw-r--r--packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx15
1 files changed, 13 insertions, 2 deletions
diff --git a/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx b/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
index 1d5896e4d..9c1a93d8e 100644
--- a/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
+++ b/packages/anastasis-webui/src/pages/home/AttributeEntryScreen.tsx
@@ -1,6 +1,6 @@
import { UserAttributeSpec, validators } from "@gnu-taler/anastasis-core";
import { isAfter, parse } from "date-fns";
-import { h, VNode } from "preact";
+import { Fragment, h, VNode } from "preact";
import { useState } from "preact/hooks";
import { DateInput } from "../../components/fields/DateInput";
import { PhoneNumberInput } from "../../components/fields/NumberInput";
@@ -122,7 +122,7 @@ for (let i = 0; i < 100; i++) {
}
function AttributeEntryField(props: AttributeEntryFieldProps): VNode {
return (
- <div>
+ <div style={{ marginTop: 16 }}>
{props.spec.type === "date" && (
<DateInput
grabFocus={props.isFirst}
@@ -151,6 +151,17 @@ function AttributeEntryField(props: AttributeEntryFieldProps): VNode {
bind={[props.value, props.setValue]}
/>
)}
+ {props.spec.type === "string" && (
+ <div>
+ This field is case-sensitive. You must enter exactly the same value
+ during recovery.
+ </div>
+ )}
+ {props.spec.name === "full_name" && (
+ <div>
+ If possible, use "LASTNAME, Firstname(s)" without abbreviations.
+ </div>
+ )}
<div class="block">
This stays private
<span class="icon is-right">