aboutsummaryrefslogtreecommitdiff
path: root/packages/aml-backoffice-ui
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2023-06-21 09:48:16 +0200
committerFlorian Dold <florian@dold.me>2023-06-21 09:48:16 +0200
commit8f8674defd7005e8916396a929788f860f42cc6f (patch)
treeadc548c808908cfb0b5c736b7d70129ff7964662 /packages/aml-backoffice-ui
parent709adb2d48c8e3c393d2ebfe2482b9947cd2c1e9 (diff)
downloadwallet-core-8f8674defd7005e8916396a929788f860f42cc6f.tar.xz
-missing toplevel 'make install' components
Diffstat (limited to 'packages/aml-backoffice-ui')
-rw-r--r--packages/aml-backoffice-ui/Makefile28
1 files changed, 23 insertions, 5 deletions
diff --git a/packages/aml-backoffice-ui/Makefile b/packages/aml-backoffice-ui/Makefile
index ddbef73b3..2653ce92f 100644
--- a/packages/aml-backoffice-ui/Makefile
+++ b/packages/aml-backoffice-ui/Makefile
@@ -1,17 +1,35 @@
# This Makefile has been placed in the public domain
-# Settings from "./configure"
-include .config.mk
+ifeq ($(TOPLEVEL), yes)
+ $(info top-level build)
+ -include ../../.config.mk
+else
+ $(info package-level build)
+ -include ../../.config.mk
+ -include .config.mk
+endif
+$(info prefix is $(prefix))
+
+.PHONY: all
all:
@echo run \'make install\' to install
spa_dir=$(prefix)/share/taler/aml-backoffice-ui
-install:
+.PHONY: install-nodeps
+install-nodeps:
+ install -d $(spa_dir)
+ install ./dist/prod/* $(spa_dir)
+
+.PHONY: deps
+deps:
pnpm install --frozen-lockfile --filter @gnu-taler/aml-backoffice-ui...
pnpm run check
pnpm run build
- install -d $(spa_dir)
- install ./dist/prod/* $(spa_dir)
+
+.PHONY: install
+install:
+ $(MAKE) deps
+ $(MAKE) install-nodeps