aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2023-09-29 12:42:38 +0200
committerChristian Grothoff <christian@grothoff.org>2023-09-29 12:43:01 +0200
commit2d196eeb62165a86854248bb114eecd18e405c74 (patch)
tree1097d329648be3f8f6281dd94cb2e80e384a1bf4 /configure.ac
parent89fb2d50127611f739ae193c009007c9b0ef546e (diff)
-bump required version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 73c7ea1c..9fe8dc8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,14 +84,14 @@ AC_CHECK_HEADERS([gnunet/gnunet_util_lib.h],
AS_IF([test $libgnunetutil != 1],
[AC_MSG_ERROR([[
***
-*** You need libgnunetutil to build this program.
+*** You need libgnunetutil >= 0.20.0 to build this program.
*** This library is part of GNUnet, available at
*** https://gnunet.org
*** ]])])
# test for postgres
-AX_LIB_POSTGRESQL([13.0])
+AX_LIB_POSTGRESQL([15.0])
AS_IF([test "x$found_postgresql" = "xyes"],
[SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$POSTGRES_CPPFLAGS $CPPFLAGS"
@@ -99,7 +99,7 @@ AS_IF([test "x$found_postgresql" = "xyes"],
AS_IF([test "x$postgres" != "x1"],
[AC_MSG_ERROR([[
***
-*** You need libpq(-dev) >= 13.0 to build this program.
+*** You need libpq(-dev) >= 15.0 to build this program.
*** ]])])
AM_CONDITIONAL([HAVE_POSTGRESQL], [test "x$postgres" = "x1"])
AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres],