aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am87
1 files changed, 28 insertions, 59 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index 9d1fe6cf4..eb4c86b0a 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,7 +1,8 @@
+# This file is in the public domain.
+
SUBDIRS = .
tmplpkgdatadir = $(prefix)/share/taler/exchange/templates/
-
dist_tmplpkgdata_DATA = \
persona-exchange-unauthorized.en.must \
persona-load-failure.en.must \
@@ -12,79 +13,47 @@ dist_tmplpkgdata_DATA = \
persona-kyc-failed.en.must \
persona-provider-failure.en.must
-# %%.must: merchant-backoffice/%.html
-# WTF: cp $< $@
-
-
-# English (en)
-tosendir=$(datadir)/taler/exchange/tos/en
+termsdir=$(datadir)/taler/exchange/
+terms_DATA = \
+ tos-v0.rst \
+ tos-bfh-v0.rst \
+ pp-v0.rst
-# English (en)
-ppendir=$(datadir)/taler/exchange/pp/en
+install-exec-local:
+ pwd
+ find locale/ -name "*.po"
+ cp --parents -r $$(find locale/ -name "*.po") $(termsdir)
rdatadir=$(datadir)/taler/exchange
-
-tosen_DATA = \
- tos/en/*.txt \
- tos/en/*.md \
- tos/en/*.pdf \
- tos/en/*.epub \
- tos/en/*.xml \
- tos/en/*.html
-
-ppen_DATA = \
- pp/en/*.txt \
- pp/en/*.md \
- pp/en/*.pdf \
- pp/en/*.epub \
- pp/en/*.xml \
- pp/en/*.html
-
rdata_DATA = \
auditor-report.tex.j2
bin_SCRIPTS = \
+ taler-terms-generator \
taler-bank-manage-testing \
taler-nexus-prepare
+edit_script = $(SED) -e 's,%termsdir%,$(termsdir),'g $(NULL)
+taler-terms-generator: taler-terms-generator.in
+ rm -f $@ $@.tmp && \
+ $(edit_script) $< >$@.tmp && \
+ chmod a-w+x $@.tmp && \
+ mv $@.tmp $@
+
+CLEANFILES = \
+ taler-terms-generator
+
EXTRA_DIST = \
- $(bin_SCRIPTS) \
- $(tosen_DATA) \
- $(ppen_DATA) \
- update-tos.sh \
- update-pp.sh \
+ locale/de/LC_MESSAGES/tos-v0.po \
+ taler-bank-manage-testing \
+ taler-nexus-prepare \
+ taler-terms-generator.in \
gana-update.sh \
gana/gnu-taler-error-codes/registry.rec \
gana/gnu-taler-error-codes/Makefile \
- tos/Makefile \
- tos/README \
- tos/bfh-v0.rst \
- tos/tos-v0.rst \
- tos/conf.py.in \
- tos/locale/de/LC_MESSAGES/tos.po \
- pp/Makefile \
- pp/README \
- pp/pp-v0.rst \
- pp/conf.py.in \
- pp/locale/de/LC_MESSAGES/pp.po \
+ $(terms_DATA) \
$(rdata_DATA) \
coverage.sh \
gnunet.tag \
microhttpd.tag \
- packages
-
-# Change the set of supported languages here. You should
-# also update tos'XX'data and EXTRA_DIST accordingly.
-TOS_LANGUAGES="en de"
-PP_LANGUAGES="en de"
-
-# Change the terms-of-service version (Etag) to generate here!
-# This value should be modified whenever there is a substantive
-# change in the original text (but not for the translations).
-TOS_VERSION=tos-v0
-PP_VERSION=pp-v0
-
-update-tos:
- VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
-update-pp:
- VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)
+ packages