aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorÖzgür Kesim <oec-taler@kesim.org>2022-03-03 19:35:24 +0100
committerÖzgür Kesim <oec-taler@kesim.org>2022-03-03 19:35:24 +0100
commit4c53d42e44cbab55194b2f0fb71ffc3cb082b56a (patch)
treead506b81aa2a8f1801224a10d1dc12795a846091 /src/util/Makefile.am
parent476ae5380823f287421885bac15871dc970d53e7 (diff)
downloadexchange-4c53d42e44cbab55194b2f0fb71ffc3cb082b56a.tar.xz
[age restriction] progress 18/n - attestation tested
- Unit-tests for commit, derive, attest and verify added, with multiple combinations of minimum age and commited age. - Fixed crypto implementation (eddsa -> ecdsa) - Using now standard functionality from GNUNET: GNUNET_CRYPTO_ecdsa_{private,public}_key_derive All tests pass (unit tests in util/ and 'make check' in testing).
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 022d0611c..a24f081b5 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -116,6 +116,7 @@ libtalerutil_la_LDFLAGS = \
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
check_PROGRAMS = \
+ test_age_restriction \
test_amount \
test_crypto \
test_helper_eddsa \
@@ -127,6 +128,11 @@ check_PROGRAMS = \
TESTS = \
$(check_PROGRAMS)
+test_age_restriction_SOURCES = \
+ test_age_restriction.c
+test_age_restriction_LDADD = \
+ -lgnunetutil \
+ libtalerutil.la
test_amount_SOURCES = \
test_amount.c