aboutsummaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorJoseph <Joseph.xu@efrei.net>2023-01-03 05:46:36 -0500
committerJoseph <Joseph.xu@efrei.net>2023-01-03 05:46:36 -0500
commit3ea5b7c52f2c44f2d29e19df2eb15222acbbd27c (patch)
tree6cf026b17927f3bc34abef42a3332ebf3640812d /src/exchangedb/Makefile.am
parentb001046a1e47fa48aacdb383ce58584b56eb2db7 (diff)
downloadexchange-3ea5b7c52f2c44f2d29e19df2eb15222acbbd27c.tar.xz
remove populate from Makefile
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am28
1 files changed, 3 insertions, 25 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 303f04fb8..3f4900192 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -295,16 +295,15 @@ check_PROGRAMS = \
bench-db-postgres\
perf-exchangedb-reserves-in-insert-postgres\
test-exchangedb-by-j-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres\
- test-exchangedb-populate-table-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres
+
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
TESTS = \
test-exchangedb-postgres\
test-exchangedb-by-j-postgres\
perf-exchangedb-reserves-in-insert-postgres\
- test-exchangedb-batch-reserves-in-insert-postgres\
- test-exchangedb-populate-table-postgres
+ test-exchangedb-batch-reserves-in-insert-postgres
test_exchangedb_postgres_SOURCES = \
test_exchangedb.c
@@ -377,27 +376,6 @@ bench_db_postgres_LDADD = \
-lgnunetutil \
$(XLIB)
-test_exchangedb_populate_table_postgres_SOURCES = \
- test_exchangedb_populate_table.c
-test_exchangedb_populate_table_postgres_LDADD = \
- libtalerexchangedb.la \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/util/libtalerutil.la \
- $(top_builddir)/src/pq/libtalerpq.la \
- -ljansson \
- -lgnunetjson \
- -lgnunetutil \
- $(XLIB)
-
-bench_db_postgres_SOURCES = \
- bench_db.c
-bench_db_postgres_LDADD = \
- libtalerexchangedb.la \
- $(top_builddir)/src/util/libtalerutil.la \
- $(top_builddir)/src/pq/libtalerpq.la \
- -lgnunetpq \
- -lgnunetutil \
- $(XLIB)
EXTRA_test_exchangedb_postgres_DEPENDENCIES = \