aboutsummaryrefslogtreecommitdiff
path: root/src/auditor/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <grothoff@gnunet.org>2024-08-14 12:33:00 +0200
committerChristian Grothoff <grothoff@gnunet.org>2024-08-14 12:33:00 +0200
commitbeac439e78b0abc18b20ff6fee5a2912c3885608 (patch)
treed6b89f969ef782948363e36e760212899aa450cd /src/auditor/Makefile.am
parentaa32787f20ee7a08775c5412608067a4ced17d98 (diff)
downloadexchange-beac439e78b0abc18b20ff6fee5a2912c3885608.tar.xz
split wire auditor
Diffstat (limited to 'src/auditor/Makefile.am')
-rw-r--r--src/auditor/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/src/auditor/Makefile.am b/src/auditor/Makefile.am
index 67bed9c7c..ab25b30f3 100644
--- a/src/auditor/Makefile.am
+++ b/src/auditor/Makefile.am
@@ -23,7 +23,8 @@ bin_PROGRAMS = \
taler-helper-auditor-deposits \
taler-helper-auditor-purses \
taler-helper-auditor-reserves \
- taler-helper-auditor-wire
+ taler-helper-auditor-wire-credit \
+ taler-helper-auditor-wire-debit
bin_SCRIPTS = \
taler-auditor \
@@ -142,9 +143,25 @@ taler_helper_auditor_reserves_LDADD = \
-taler_helper_auditor_wire_SOURCES = \
- taler-helper-auditor-wire.c
-taler_helper_auditor_wire_LDADD = \
+taler_helper_auditor_wire_credit_SOURCES = \
+ taler-helper-auditor-wire-credit.c
+taler_helper_auditor_wire_credit_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/auditordb/libtalerauditordb.la \
+ libauditorreport.la \
+ -ljansson \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ $(XLIB)
+
+taler_helper_auditor_wire_debit_SOURCES = \
+ taler-helper-auditor-wire-debit.c
+taler_helper_auditor_wire_debit_LDADD = \
$(LIBGCRYPT_LIBS) \
$(top_builddir)/src/json/libtalerjson.la \
$(top_builddir)/src/util/libtalerutil.la \