aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-12-19 13:29:07 +0100
committerChristian Grothoff <christian@grothoff.org>2022-12-19 13:29:07 +0100
commit24c0969873d81b9a0ba55e59d71d8beb19db3bb2 (patch)
tree2d89436365c861231fee91da1c3efd60d53483fc /configure.ac
parenta03e4fa72fad4c30bac9719fbfea39947f0bf646 (diff)
downloadexchange-24c0969873d81b9a0ba55e59d71d8beb19db3bb2.tar.xz
ensure Postgres CPPFLAGS are set before libgnunetpq check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bbbce187f..eb78c891c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -271,7 +271,8 @@ AS_CASE([$with_gnunet],
[yes], [],
[no], [AC_MSG_ERROR([--with-gnunet is required])],
[LDFLAGS="-L$with_gnunet/lib $LDFLAGS"
- CPPFLAGS="-I$with_gnunet/include ${CPPFLAGS} ${POSTGRESQL_CPPFLAGS}"])
+ CPPFLAGS="-I$with_gnunet/include ${CPPFLAGS}"])
+CPPFLAGS="${CPPFLAGS} ${POSTGRESQL_CPPFLAGS}"
AC_CHECK_HEADERS([gnunet/gnunet_pq_lib.h],
[AC_CHECK_LIB([gnunetpq], [GNUNET_PQ_result_spec_string], libgnunetpq=1)])
AS_IF([test $libgnunetpq != 1],