aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlack Coder <slackcoder@server.ky>2022-09-24 06:34:34 -0500
committerSlack Coder <slackcoder@server.ky>2022-09-24 06:35:13 -0500
commitc2fb1bd95d1709927d7bd7058a162d39e593a1ee (patch)
tree12221dcab0e2848cbb53acde13c62c46d9e05ef0
parent44bc538eff1f1e74d75c282d7980ed98e342e079 (diff)
downloadslackbuilds-c2fb1bd95d1709927d7bd7058a162d39e593a1ee.tar.gz
pytz: import and bump 2022.2.1
Slackbuild's script should install for python3 as well.
-rw-r--r--pytz/README5
-rw-r--r--pytz/pytz.SlackBuild83
-rw-r--r--pytz/pytz.info10
-rw-r--r--pytz/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/pytz/README b/pytz/README
new file mode 100644
index 0000000..354f8ea
--- /dev/null
+++ b/pytz/README
@@ -0,0 +1,5 @@
+pytz brings the Olson tz database into Python. This library allows
+accurate and cross platform timezone calculations using Python 2.3
+or higher. It also solves the issue of ambiguous times at the end
+of daylight savings, which you can read more about in the Python
+Library Reference (datetime.tzinfo).
diff --git a/pytz/pytz.SlackBuild b/pytz/pytz.SlackBuild
new file mode 100644
index 0000000..dc4f2be
--- /dev/null
+++ b/pytz/pytz.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Slackware build script for pytz
+
+# Copyright 2009-2021 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pytz
+VERSION=${VERSION:-2022.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt PKG-INFO README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/pytz/pytz.info b/pytz/pytz.info
new file mode 100644
index 0000000..811f871
--- /dev/null
+++ b/pytz/pytz.info
@@ -0,0 +1,10 @@
+PRGNAM="pytz"
+VERSION="2022.2.1"
+HOMEPAGE="https://launchpad.net/pytz"
+DOWNLOAD="https://files.pythonhosted.org/packages/24/0c/401283bb1499768e33ddd2e1a35817c775405c1f047a9dc088a29ce2ea5d/pytz-2022.2.1.tar.gz"
+MD5SUM="5c7aa995be1a0091df9774502f84be4b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@slackbuilds.org"
diff --git a/pytz/slack-desc b/pytz/slack-desc
new file mode 100644
index 0000000..fcd5149
--- /dev/null
+++ b/pytz/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pytz: pytz (World timezone definitions for Python)
+pytz:
+pytz: pytz brings the Olson tz database into Python. This library allows
+pytz: accurate and cross platform timezone calculations using Python 2.3
+pytz: or higher. It also solves the issue of ambiguous times at the end
+pytz: of daylight savings, which you can read more about in the Python
+pytz: Library Reference (datetime.tzinfo).
+pytz:
+pytz: Homepage: https://launchpad.net/pytz
+pytz:
+pytz: