aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlack Coder <slackcoder@server.ky>2024-04-09 09:55:23 -0500
committerSlack Coder <slackcoder@server.ky>2024-04-09 09:55:23 -0500
commit09f278db0cc2582f67d695645be8683ec50e95c3 (patch)
tree4ac439b4bce9339fa7d62526016c707ba73355e7
parentbe3c1db29c07c160ff07d5f9c66be8d3e904866c (diff)
downloadslackbuilds-09f278db0cc2582f67d695645be8683ec50e95c3.tar.xz
Remove builds to support taler's git code
Some packages were required to support building taler packages from their git source code. Remove these to reduce the maintenance burden.
-rw-r--r--pydata-sphinx-theme/README1
-rw-r--r--pydata-sphinx-theme/pydata-sphinx-theme.SlackBuild94
-rw-r--r--pydata-sphinx-theme/pydata-sphinx-theme.info10
-rw-r--r--pydata-sphinx-theme/slack-desc19
-rw-r--r--python3-HTMLArk/README1
-rw-r--r--python3-HTMLArk/python3-HTMLArk.SlackBuild93
-rw-r--r--python3-HTMLArk/python3-HTMLArk.info10
-rw-r--r--python3-HTMLArk/slack-desc15
-rw-r--r--python3-pep621/README1
-rw-r--r--python3-pep621/python3-pep621.SlackBuild94
-rw-r--r--python3-pep621/python3-pep621.info10
-rw-r--r--python3-pep621/slack-desc17
-rw-r--r--sphinx-book-theme/README1
-rw-r--r--sphinx-book-theme/slack-desc19
-rw-r--r--sphinx-book-theme/sphinx-book-theme.SlackBuild94
-rw-r--r--sphinx-book-theme/sphinx-book-theme.info10
-rw-r--r--sphinx-theme-builder/README7
-rw-r--r--sphinx-theme-builder/slack-desc19
-rw-r--r--sphinx-theme-builder/sphinx-theme-builder.SlackBuild93
-rw-r--r--sphinx-theme-builder/sphinx-theme-builder.info10
20 files changed, 0 insertions, 618 deletions
diff --git a/pydata-sphinx-theme/README b/pydata-sphinx-theme/README
deleted file mode 100644
index 10e9d05..0000000
--- a/pydata-sphinx-theme/README
+++ /dev/null
@@ -1 +0,0 @@
-The pydata sphinx theme.
diff --git a/pydata-sphinx-theme/pydata-sphinx-theme.SlackBuild b/pydata-sphinx-theme/pydata-sphinx-theme.SlackBuild
deleted file mode 100644
index e73f292..0000000
--- a/pydata-sphinx-theme/pydata-sphinx-theme.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for pydata_sphinx_theme.
-
-# Copyright (c) 2024 Slack Coder <slackcoder@server.ky>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pydata-sphinx-theme
-SRCNAM=pydata_sphinx_theme
-VERSION=${VERSION:-0.14.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_slackcoder}
-PKGTYPE=${PKGTYPE:-txz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m build --wheel
-python3 -m installer --destdir "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/pydata-sphinx-theme/pydata-sphinx-theme.info b/pydata-sphinx-theme/pydata-sphinx-theme.info
deleted file mode 100644
index 837ac52..0000000
--- a/pydata-sphinx-theme/pydata-sphinx-theme.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pydata-sphinx-theme"
-VERSION="0.14.4"
-HOMEPAGE="https://pypi.org/project/sphinx-sphinx-theme"
-DOWNLOAD="https://files.pythonhosted.org/packages/de/47/1bc31c4bc8b395cd37d8ceaf720abe10cf64c857fb9ce55856a6dd958484/pydata_sphinx_theme-0.14.4.tar.gz"
-MD5SUM="8d2070f7a82bc55f16bea7ebfc2457d0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Sphinx sphinx-theme-builder python3-rich nodeenv BeautifulSoup4"
-MAINTAINER="Slack Coder"
-EMAIL="slackcoder@server.ky"
diff --git a/pydata-sphinx-theme/slack-desc b/pydata-sphinx-theme/slack-desc
deleted file mode 100644
index cb6f869..0000000
--- a/pydata-sphinx-theme/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pydata-sphinx-theme: pydata-sphinx-theme
-pydata-sphinx-theme:
-pydata-sphinx-theme: The pydata-sphinx-theme is a sphinx theme.
-pydata-sphinx-theme:
-pydata-sphinx-theme:
-pydata-sphinx-theme:
-pydata-sphinx-theme: Homepage: https://pypi.org/project/pydata-sphinx-theme
-pydata-sphinx-theme:
-pydata-sphinx-theme:
-pydata-sphinx-theme:
-pydata-sphinx-theme:
diff --git a/python3-HTMLArk/README b/python3-HTMLArk/README
deleted file mode 100644
index 554c4e0..0000000
--- a/python3-HTMLArk/README
+++ /dev/null
@@ -1 +0,0 @@
-Pack a webpage including support files into a single HTML file.
diff --git a/python3-HTMLArk/python3-HTMLArk.SlackBuild b/python3-HTMLArk/python3-HTMLArk.SlackBuild
deleted file mode 100644
index 16a2ff1..0000000
--- a/python3-HTMLArk/python3-HTMLArk.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for python3-pep621.
-
-# Copyright (c) 2024 Slack Coder <slackcoder@server.ky>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-HTMLArk
-SRCNAM=HTMLArk
-VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_slackcoder}
-PKGTYPE=${PKGTYPE:-txz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m build --wheel --no-isolation
-python3 -m installer --destdir "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python3-HTMLArk/python3-HTMLArk.info b/python3-HTMLArk/python3-HTMLArk.info
deleted file mode 100644
index 24a6749..0000000
--- a/python3-HTMLArk/python3-HTMLArk.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-HTMLArk"
-VERSION="1.0.0"
-HOMEPAGE="https://pypi.org/project/HTMLArk"
-DOWNLOAD="https://files.pythonhosted.org/packages/d7/0a/c5150fb593abf13dd58ae3e3b46da56266d3f8aff8c0fc512f2001fa35a3/HTMLArk-1.0.0.tar.gz"
-MD5SUM="bcbdd16ae936cf03de478de6bf49bd7f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="nodeenv"
-MAINTAINER="Slack Coder"
-EMAIL="slackcoder@server.ky"
diff --git a/python3-HTMLArk/slack-desc b/python3-HTMLArk/slack-desc
deleted file mode 100644
index c353c50..0000000
--- a/python3-HTMLArk/slack-desc
+++ /dev/null
@@ -1,15 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-HTMLArk: python3-HTMLArk
-python3-HTMLArk:
-python3-HTMLArk: Pack a webpage including support files into a single HTML file.
-python3-HTMLArk:
-python3-HTMLArk: Homepage: https://pypi.org/project/HTMLArk
-python3-HTMLArk:
-python3-HTMLArk:
diff --git a/python3-pep621/README b/python3-pep621/README
deleted file mode 100644
index 47606e5..0000000
--- a/python3-pep621/README
+++ /dev/null
@@ -1 +0,0 @@
-Python3 dataclass for PEP 621 metadata with support for core metadata generation
diff --git a/python3-pep621/python3-pep621.SlackBuild b/python3-pep621/python3-pep621.SlackBuild
deleted file mode 100644
index 073e1f6..0000000
--- a/python3-pep621/python3-pep621.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for python3-pep621.
-
-# Copyright (c) 2024 Slack Coder <slackcoder@server.ky>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-pep621
-SRCNAM=pep621
-VERSION=${VERSION:-0.4.0.post2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_slackcoder}
-PKGTYPE=${PKGTYPE:-txz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m build --wheel --no-isolation
-python3 -m installer --destdir "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python3-pep621/python3-pep621.info b/python3-pep621/python3-pep621.info
deleted file mode 100644
index 0651f3d..0000000
--- a/python3-pep621/python3-pep621.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-pep621"
-VERSION="0.4.0.post2"
-HOMEPAGE="https://pypi.org/project/python3-pep621"
-DOWNLOAD="https://files.pythonhosted.org/packages/92/2d/4718504232643fb69291485f509e0e72b8135de19fceaf4d03c8c16f268c/pep621-0.4.0.post2.tar.gz"
-MD5SUM="11a9f2ceebbf49f185c2693d194e61bd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="nodeenv"
-MAINTAINER="Slack Coder"
-EMAIL="slackcoder@server.ky"
diff --git a/python3-pep621/slack-desc b/python3-pep621/slack-desc
deleted file mode 100644
index d933972..0000000
--- a/python3-pep621/slack-desc
+++ /dev/null
@@ -1,17 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-pep621: python3-pep621
-python3-pep621:
-python3-pep621: Python3 dataclass for PEP 621 metadata with support for core metadata
-python3-pep621: generation.
-python3-pep621:
-python3-pep621: Homepage: https://pypi.org/project/pep621
-python3-pep621:
-python3-pep621:
-python3-pep621:
diff --git a/sphinx-book-theme/README b/sphinx-book-theme/README
deleted file mode 100644
index 8110968..0000000
--- a/sphinx-book-theme/README
+++ /dev/null
@@ -1 +0,0 @@
-The sphinx book theme.
diff --git a/sphinx-book-theme/slack-desc b/sphinx-book-theme/slack-desc
deleted file mode 100644
index f879d97..0000000
--- a/sphinx-book-theme/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sphinx-book-theme: sphinx-book-theme (decorator for caching properties in classes)
-sphinx-book-theme:
-sphinx-book-theme: The sphinx-book-theme is a sphinx theme.
-sphinx-book-theme:
-sphinx-book-theme:
-sphinx-book-theme:
-sphinx-book-theme: Homepage: https://pypi.org/project/sphinx-book-theme
-sphinx-book-theme:
-sphinx-book-theme:
-sphinx-book-theme:
-sphinx-book-theme:
diff --git a/sphinx-book-theme/sphinx-book-theme.SlackBuild b/sphinx-book-theme/sphinx-book-theme.SlackBuild
deleted file mode 100644
index 537711e..0000000
--- a/sphinx-book-theme/sphinx-book-theme.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for sphinx_book_theme
-
-# Copyright (c) 2024 Slack Coder <slackcoder@server.ky>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sphinx-book-theme
-SRCNAM=sphinx_book_theme
-VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_slackcoder}
-PKGTYPE=${PKGTYPE:-txz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m build --wheel
-python3 -m installer --destdir "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/sphinx-book-theme/sphinx-book-theme.info b/sphinx-book-theme/sphinx-book-theme.info
deleted file mode 100644
index 4bd5ef3..0000000
--- a/sphinx-book-theme/sphinx-book-theme.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sphinx-book-theme"
-VERSION="1.1.0"
-HOMEPAGE="https://pypi.org/project/sphinx-book-theme"
-DOWNLOAD="https://files.pythonhosted.org/packages/7a/4a/01316bd8a29ad546fd78f460fd958b5a08b3336a6625d96de9b5d149a0e7/sphinx_book_theme-1.1.0.tar.gz"
-MD5SUM="b9e67d52ba5227811996c83e2ec84065"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Sphinx python3-pep621 pydata-sphinx-theme sphinx-theme-builder python3-rich nodeenv"
-MAINTAINER="Slack Coder"
-EMAIL="slackcoder@server.ky"
diff --git a/sphinx-theme-builder/README b/sphinx-theme-builder/README
deleted file mode 100644
index 4975c2b..0000000
--- a/sphinx-theme-builder/README
+++ /dev/null
@@ -1,7 +0,0 @@
-The sphinx_rtd_theme is a sphinx theme designed to look modern and be
-mobile-friendly.
-
-This theme is primarily focused to be used on readthedocs.org but can
-work with your own sphinx projects.
-
-To read more and see a working demo head over to readthedocs.org.
diff --git a/sphinx-theme-builder/slack-desc b/sphinx-theme-builder/slack-desc
deleted file mode 100644
index be0b12f..0000000
--- a/sphinx-theme-builder/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sphinx-theme-builder: sphinx-theme-builder
-sphinx-theme-builder:
-sphinx-theme-builder: Streamline the Sphinx theme development workflow, by building upon
-sphinx-theme-builder: existing standardised tools.
-sphinx-theme-builder:
-sphinx-theme-builder:
-sphinx-theme-builder: Homepage: https://pypi.org/project/sphinx-theme-builder
-sphinx-theme-builder:
-sphinx-theme-builder:
-sphinx-theme-builder:
-sphinx-theme-builder:
diff --git a/sphinx-theme-builder/sphinx-theme-builder.SlackBuild b/sphinx-theme-builder/sphinx-theme-builder.SlackBuild
deleted file mode 100644
index 3a2610f..0000000
--- a/sphinx-theme-builder/sphinx-theme-builder.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/bash
-
-# SlackBuild build script for sphinx_theme_builder
-
-# Copyright (c) 2024 Slack Coder <slackcoder@server.ky>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sphinx-theme-builder
-VERSION=${VERSION:-0.2.0a7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_slackcoder}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 -m build --wheel --no-isolation
-python3 -m installer --destdir "$PKG" dist/*.whl
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/sphinx-theme-builder/sphinx-theme-builder.info b/sphinx-theme-builder/sphinx-theme-builder.info
deleted file mode 100644
index e8ec123..0000000
--- a/sphinx-theme-builder/sphinx-theme-builder.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sphinx-theme-builder"
-VERSION="0.2.0a7"
-HOMEPAGE="https://pypi.org/project/sphinx-theme-builder"
-DOWNLOAD="https://files.pythonhosted.org/packages/37/67/c4a49681104ef3d019bf58c880f9609c22aabfbb0e9538797c0f356fe120/sphinx-theme-builder-0.2.0a7.tar.gz"
-MD5SUM="194df3d98fbcc8f2a5317c4f4a73a6ca"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-pyproject-metadata nodejs"
-MAINTAINER="Slack Coder"
-EMAIL="slackcoder@server.ky"