aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python3-gearbox/README (renamed from python/gearbox/README)0
-rw-r--r--python/python3-gearbox/python3-gearbox.SlackBuild (renamed from python/gearbox/gearbox.SlackBuild)10
-rw-r--r--python/python3-gearbox/python3-gearbox.info (renamed from python/gearbox/gearbox.info)4
-rw-r--r--python/python3-gearbox/slack-desc (renamed from python/gearbox/slack-desc)24
4 files changed, 19 insertions, 19 deletions
diff --git a/python/gearbox/README b/python/python3-gearbox/README
index 532387598ffd..532387598ffd 100644
--- a/python/gearbox/README
+++ b/python/python3-gearbox/README
diff --git a/python/gearbox/gearbox.SlackBuild b/python/python3-gearbox/python3-gearbox.SlackBuild
index 3d7be92cf949..9d6e95ee3581 100644
--- a/python/gearbox/gearbox.SlackBuild
+++ b/python/python3-gearbox/python3-gearbox.SlackBuild
@@ -22,7 +22,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=gearbox
+PRGNAM=python3-gearbox
+SRCNAM=${PRGNAM#python3-*}
VERSION=${VERSION:-0.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,9 +54,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -63,7 +64,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/gearbox/gearbox.info b/python/python3-gearbox/python3-gearbox.info
index 5e43dedad27f..c5a31f60f514 100644
--- a/python/gearbox/gearbox.info
+++ b/python/python3-gearbox/python3-gearbox.info
@@ -1,10 +1,10 @@
-PRGNAM="gearbox"
+PRGNAM="python3-gearbox"
VERSION="0.2.1"
HOMEPAGE="https://github.com/TurboGears/gearbox"
DOWNLOAD="https://github.com/TurboGears/gearbox/archive/0.2.1/gearbox-0.2.1.tar.gz"
MD5SUM="286e7c6f73b61a41b5fd416ba2c835ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="hupper PasteDeploy tempita"
+REQUIRES="python3-hupper python3-pastedeploy tempita"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"
diff --git a/python/gearbox/slack-desc b/python/python3-gearbox/slack-desc
index b4b0912eb913..50443be50b71 100644
--- a/python/gearbox/slack-desc
+++ b/python/python3-gearbox/slack-desc
@@ -5,15 +5,15 @@
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
- |-----handy-ruler------------------------------------------------------|
-gearbox: gearbox (Python module)
-gearbox:
-gearbox: Command line toolkit born as a paster command replacement for the
-gearbox: TurboGears2 web framework
-gearbox:
-gearbox:
-gearbox:
-gearbox:
-gearbox:
-gearbox:
-gearbox:
+ |-----handy-ruler------------------------------------------------------|
+python3-gearbox: python3-gearbox (Python module)
+python3-gearbox:
+python3-gearbox: Command line toolkit born as a paster command replacement for the
+python3-gearbox: TurboGears2 web framework
+python3-gearbox:
+python3-gearbox:
+python3-gearbox:
+python3-gearbox:
+python3-gearbox:
+python3-gearbox:
+python3-gearbox: