aboutsummaryrefslogtreecommitdiff
path: root/python/rst2pdf/rst2pdf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/rst2pdf/rst2pdf.SlackBuild')
-rw-r--r--python/rst2pdf/rst2pdf.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/rst2pdf/rst2pdf.SlackBuild b/python/rst2pdf/rst2pdf.SlackBuild
index 06e6c0f95f..51ac3c128a 100644
--- a/python/rst2pdf/rst2pdf.SlackBuild
+++ b/python/rst2pdf/rst2pdf.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rst2pdf
-VERSION=${VERSION:-0.102}
+VERSION=${VERSION:-0.103.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,7 +63,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
cd doc
rst2man rst2pdf.rst rst2pdf.1