aboutsummaryrefslogtreecommitdiff
path: root/python/python3-tubes/python3-tubes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-tubes/python3-tubes.SlackBuild')
-rw-r--r--python/python3-tubes/python3-tubes.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/python3-tubes/python3-tubes.SlackBuild b/python/python3-tubes/python3-tubes.SlackBuild
index d07c4b1d04..3e7b9fb464 100644
--- a/python/python3-tubes/python3-tubes.SlackBuild
+++ b/python/python3-tubes/python3-tubes.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-tubes
SRCNAM=Tubes
VERSION=${VERSION:-0.2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -83,6 +80,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \