aboutsummaryrefslogtreecommitdiff
path: root/python/python3-treq
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-treq')
-rw-r--r--python/python3-treq/README5
-rw-r--r--python/python3-treq/python3-treq.SlackBuild77
-rw-r--r--python/python3-treq/python3-treq.info10
-rw-r--r--python/python3-treq/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/python3-treq/README b/python/python3-treq/README
new file mode 100644
index 0000000000..cb7d4bd530
--- /dev/null
+++ b/python/python3-treq/README
@@ -0,0 +1,5 @@
+treq: High-level Twisted HTTP Client API
+
+treq is an HTTP library inspired by requests but written on top of
+Twisted's Agents. It provides a simple, higher level API for making
+HTTP requests when using Twisted.
diff --git a/python/python3-treq/python3-treq.SlackBuild b/python/python3-treq/python3-treq.SlackBuild
new file mode 100644
index 0000000000..09883a8486
--- /dev/null
+++ b/python/python3-treq/python3-treq.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# Slackware build script for python3-treq
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-treq
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-24.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-treq/python3-treq.info b/python/python3-treq/python3-treq.info
new file mode 100644
index 0000000000..0233fad7b9
--- /dev/null
+++ b/python/python3-treq/python3-treq.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-treq"
+VERSION="24.9.1"
+HOMEPAGE="https://pypi.org/project/treq/"
+DOWNLOAD="https://pypi.python.org/packages/source/t/treq/treq-24.9.1.tar.gz"
+MD5SUM="a48996ff540651deded304b638ba54ea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyOpenSSL python3-twisted"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-treq/slack-desc b/python/python3-treq/slack-desc
new file mode 100644
index 0000000000..3b9145f477
--- /dev/null
+++ b/python/python3-treq/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-treq: python3-treq (High-level Twisted HTTP Client API)
+python3-treq:
+python3-treq: treq is an HTTP library inspired by requests but written on top of
+python3-treq: Twisted's Agents.
+python3-treq:
+python3-treq: It provides a simple, higher level API for making HTTP requests when
+python3-treq: using Twisted.
+python3-treq:
+python3-treq:
+python3-treq:
+python3-treq: