aboutsummaryrefslogtreecommitdiff
path: root/python/python3-resolvelib/python3-resolvelib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-resolvelib/python3-resolvelib.SlackBuild')
-rw-r--r--python/python3-resolvelib/python3-resolvelib.SlackBuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/python/python3-resolvelib/python3-resolvelib.SlackBuild b/python/python3-resolvelib/python3-resolvelib.SlackBuild
index d75e6c3e5b..74e0efddff 100644
--- a/python/python3-resolvelib/python3-resolvelib.SlackBuild
+++ b/python/python3-resolvelib/python3-resolvelib.SlackBuild
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-resolvelib
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.0}
SRCNAM=${SRCNAM:-resolvelib}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,6 +62,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl