aboutsummaryrefslogtreecommitdiff
path: root/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pyproject-api/python3-pyproject-api.SlackBuild')
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index fef1bf5318..e5770e14d6 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pyproject-api
-# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2025 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-api
-VERSION=${VERSION:-1.8.0}
+VERSION=${VERSION:-1.9.0}
SRCNAM=${SRCNAM:-pyproject-api}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -66,8 +66,8 @@ PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
-# Revert unnecessary dependency version requirements
-sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
+# Revert seemingly unnecessary dependency version requirements
+sed -i 's|2\.2\.1|1\.2\.2|' pyproject.toml # tomli
# Hide warning for packaging>=24 since it resides in /opt/
sed -i 's|.*packaging.*||' pyproject.toml